WordPress 2.5.1 yayınlandı! Bloglarınızı upgrade edin!

Evet arkadaşlar, beklediğimden kısa süre içerisinde wordpress 2.5.1 sürümü çıktı, sürümde çok önemli bir güvenlik problemi fixlendi. Benim gibi wordpress 2.5 kullanan kişilerin bloglarını acilen güncellemesi gerektiğini söylüyorlar. Bu güvenlik açığının şu anda gizli tutulduğunu ama kısa süre içerisinde duyulabileceğine dikkat çekmişler, bu yüzden şiddetle bir an önce bloglarınızı güncelleyin diyorlar.

Ryan tarafından yapılan açıklama ve çevirisi aşağıdaki şekilde:

Version 2.5.1 of WordPress is now available. It includes a number of bug fixes, performance enhancements, and one very important security fix. We recommend everyone update immediately, particularly if your blog has open registration. The vulnerability is not public but it will be shortly.

In addition to the security fix, 2.5.1 contains many bug fixes. If you are interested only in the security fixes, you can download these corrected copies of wp-includes/pluggable.php, wp-admin/includes/media.php, and wp-admin/media.php. Replace your existing copies of these files with these new copies.

If you download the entire 2.5.1 release, you will be getting over 70 other fixes. 2.5.1 focuses on fixing the most annoying bugs and improving performance. Here are some highlights:

  • Performance improvements for the Dashboard, Write Post, and Edit Comments pages.
  • Better performance for those who have many categories
  • Media Uploader fixes
  • An upgrade to TinyMCE 3.0.7
  • Widget Administration fixes
  • Various usability improvements
  • Layout fixes for IE

Secret lives of blogs

Since 2.5 your wp-config.php file allows a new constant called SECRET_KEY which basically is meant to introduce a little permanent randomness into the cryptographic functions used for cookies in WordPress. You can visit this link we set up to get a unique secret key for your config file. (It’s unique and random on every page load.) Having this line in your config file helps secure your blog.

Many thanks to Steven Murdoch for responsibly reporting the security issue (CVE-2008-1930) and Alex Concha for reporting an XSS issue.

Kendimce elimden geldiği kadar çevirisini yapıyorum. Ufak tefek anlam eksiklikleri olabilir, bilginize.

WordPress 2.5.1 sürümü şu anda kullanımda. Az olan buglar fixlendi, performans arttırıldı, ve çok önemli güvenlik fixlemesi yapıldı. Herkese bloglarını acilen güncellemelerini tavsiye ediyoruz, özellikle de kullanıcı kaydı açık olan bloglar. Güvenlik açığı şu anda duyurulmuş değildir fakat kısa süre içerisinde yayılacaktır.

Bu güvenlik güncellemesinde hem de birçok bug fixlendi. Eğer sadece güvenlik açıklarını fixlemeyi düşünüyorsanız, belirtilen doğru kopyaları download etmeniz(indirmeniz) ve mevcut dosyalarla değiştirmeniz yeterlidir. Değiştirilen dosyalar wp-includes/pluggable.php, wp-admin/includes/media.php, ve wp-admin/media.php

Eğer sadece wordpress 2.5.1 sürümünü indirdiyseniz, 70’in üzerinde diğer fixlemeler ‘e sahip olmuş olacaksınız. 2.5.1 sürümü daha çok bug fixleme ve performans arttırma üzerine yoğunlaşarak yapılmıştır. İşte birkaç ana hat:

  • Kontrol paneli, Write Post paneli(Yazı yazma paneli yani) ve Edit Comments(Yorumları Düzenle) sayfalarında performans yükseltmesi yapıldı.
  • Çok kategori içeren yerlerde daha yüksek performans sağlandı.
  • Media Uploader fixlendi. (ki zaten bu media uploader’daki sorunu ilk yüklediğimde farketmiştim, temamdan kaynaklandığını düşünüp blogumda kullandığım Mandigo Theme ‘nin yapımcısı Tom‘un başının etini çok ağrıtmıştım, neyse.)
  • TinyMCE, 3.0.7 sürümüne yükseltildi.
  • Çeşitli kullanılırlıklar yükseltildi. (Tam anlamadım bu kısmını)
  • IE güncellemeleri yapıldı.

Blogların Gizli Yaşamları

WordPress 2.5 sürümünden beri wp-config.php dosyası SECRET_KEY ismi verilen bir değişmeze sahip oldu. Cookie’lerde güvenliği sağlamak için bu secret key’i kullanabileceğimizi söylüyorlar. İlgilenen kişilerin bu adresi ziyaret ederek eşsiz secret key’e sahip olabileceğini söylüyorlar.(Her yenilenen sayfa eşsiz bir key üretiyor) Bu kodu kullanmanız da blog sayfanızı daha güvenli hale getirmenize imkan tanıyor.

WordPress ekibi iyi çalışıyor, tebrikler. Bloglarınızı güncellemeyi ihmal etmeyin!

Mehmet.

, , , , , , , , , , , , , , , , , ,

  • Pingback: Wordpress 2.5.1 yay()

  • http://fly.org fly

    haberdar insanlardan bunlari duymak bizim icin gercekten iyi oluyor yeni haberdar profesyoneller yetistiriyorsunuz :) sagolun.

Powered by WordPress. Designed by WooThemes

%d blogcu bunu beğendi: